Vous avez apprécié ?
Cliquez ;-)

Fonction Excel : NB_TEXTE

La fonction Excel NB_TEXTE compte le nombre de fois qu'une valeur apparaît dans un texte.

=NB_TEXTE(texte; valeur_recherchée)


Exemples d'utilisation :

Compter le nombre de fois où le mot "Jean" apparaît dans le texte =NB_TEXTE(A1;"Jean") :

fonction-excel-nb-texte - nb-texte

Compter le nombre de fois où le chiffre 5 apparaît dans le texte =NB_TEXTE(A1;5) :

fonction-excel-nb-chiffre - nb-texte

En combinant cette fonction avec la fonction SI, vous pouvez par exemple vérifier si une valeur apparaît dans un texte et effectuer une action en conséquence. Le but de ce dernier exemple est de vérifier si le chiffre du milieu du n° de référence est le "01" =SI(NB_TEXTE(A1;"-01-")>0;"Oui";"Non") :

fonction-excel-si-texte-trouve - nb-texte

Remarque : cette fonction nécessite l'installation du pack de fonctions XLP (un add-in gratuit pour Excel qui ajoute 65 nouvelles fonctions).