Fonction Excel : SI_NON_VIDE

La fonction Excel SI_NON_VIDE vérifie si une cellule est vide et retourne un résultat en fonction de ce test.

=SI_NON_VIDE(cellule; valeur_si_oui; valeur_si_non)

ou

=SI_NON_VIDE(cellule; valeur_si_oui)

ou

=SI_NON_VIDE(cellule; ; valeur_si_non)


Exemples d'utilisation :

La fonction SI est souvent utilisée pour vérifier si une cellule est vide avant d'effectuer une action. Le but de la fonction SI_NON_VIDE est de simplifier encore ce test.

La formule =SI_NON_VIDE(A1;"Non vide";"Vide") est donc équivalente à =SI(A1<>"";"Non vide";"Vide") :

fonction-excel-si-non-vide - si-non-vide

Vous n'êtes pas obligé de compléter d'entrer des valeurs pour "valeur_si_oui" et "valeur_si_non" si vous n'en avez pas l'utilité.

Un exemple avec uniquement la valeur si non vide =SI_NON_VIDE(A1;A1*2) :

fonction-excel-calcul-si-non-vide - si-non-vide

Remarque : cette fonction nécessite l'installation du pack de fonctions XLP (un add-in gratuit pour Excel qui ajoute 65 nouvelles fonctions).