Formation Excel : validation de données

La validation de données permet de s'assurer de la validité des données entrées et d'afficher un message d'erreur et refuser l'entrée si les données ne sont pas valides.

Le fichier d'exemple : lecon-10.xlsx


Validation en fonction d'une plage

Sélectionnez la plage qui devra contenir des données valides et cliquez sur "Validation des données" à partir de l'onglet "Données" :

excel validation donnees

Choisissez ensuite "Liste" et sélectionnez la plage de cellules qui composera la liste des données autorisées :

excel validation donnees plage

L'avantage avec la validation par liste est que la liste des choix autorisés est ensuite affichée sous forme de liste déroulante :

excel validation donnees liste deroulante

Validation en fonction d'un nombre

Pour appliquer une validation de données en fonction d'une valeur numérique, sélectionnez le choix "Nombre entier" ou "Décimal" si les nombres à virgule sont autorisés :

excel validation donnees nombre

Dans ce cas, seuls les nombres entiers de 1 à 100 sont autorisés. Dans le cas contraire, un message d'erreur est retourné et l'entrée est refusée :

excel validation donnees message erreur

Validation par date ou heure

Il est également possible de valider des données en fonction de la date ou de l'heure. Dans ce cas, la date entrée devra être supérieure à celle indiquée :

excel validation donnees date

Validation en fonction du nombre de caractères

La validation de données permet aussi de définir le nombre de caractères autorisés. Dans ce cas, le nombre de caractères devra se situer entre 4 et 12 :

excel validation donnees nombre caracteres

Pour afficher un message informatif lors de la saisie, définissez ce message depuis le second onglet :

excel validation donnees message saisie

Pour rendre le message d'erreur plus compréhensible pour l'utilisateur, vous pouvez le personnaliser depuis l'onglet "Alerte d'erreur" :

excel validation donnees alerte erreur

Pour afficher un message personnalisé en cas d'erreur :

excel validation donnees message erreur personnalise

Validation en fonction d'une formule

Lorsqu'aucun autre mode de validation ne convient, choisissez la validation par formule pour des validations de données beaucoup plus personnalisées.

Dans cet exemple, la formule =NB.SI($B$2:$B$13;B2)=1 (qui vérifie s'il n'y a qu'une seule fois la valeur entrée dans la plage de cellules) affichera un avertissement en cas de doublons :

excel validation donnees formule

Ici, le "D" est entré à double, l'avertissement est alors affiché :

excel validation donnees doublons
Télécharger ce cours au format PDF