Fonction Excel : SIERREUR

La fonction Excel SIERREUR vérifie si la valeur entrée est une erreur, elle retourne ensuite cette même valeur s'il n'y a aucune erreur ou une autre valeur définie en cas d'erreur.

Utilisation :

=SIERREUR(valeur, valeur_si_erreur)


Cas pratique

Reprenons l'exemple de la fonction RECHERCHEV qui affiche le nombre de points en fonction du numéro de dossier entré :

fonction-excel-recherchev - sierreur

Le problème dans ce cas est qu'une erreur sera affichée si aucun résultat n'est trouvé :

fonction-excel-recherchev-erreur - sierreur

Sans la fonction SIERREUR, il faudrait utiliser la fonction SI ainsi qu'une autre fonction pour tester si la fonction RECHERCHEV renvoie une erreur et retourner le résultat de la fonction RECHERCHEV si tout va bien ou une autre valeur en cas d'erreur :

=SI(ESTERREUR(RECHERCHEV(E2;A2:C11;3;FAUX));"-";RECHERCHEV(E2;A2:C11;3;FAUX))

La formule est donc inutilement longue et la fonction RECHERCHEV y est présente à double ...

La fonction SIERREUR permet de simplifier tout cela en testant une valeur et en renvoyant directement cette même valeur s'il n'y a aucune erreur (ou une autre en cas d'erreur) :

=SIERREUR(RECHERCHEV(E2;A2:C11;3;FAUX);"-")

fonction-excel-recherchev-sierreur - sierreur

En cas de besoin, vous pouvez télécharger le fichier Excel de cet exemple : sierreur.xlsx