Formation Excel : fonction SI et imbrications

Faire référence aux cellules

Au lieu d'afficher "Oui" ou "Non" en fonction de l'âge comme c'était le cas à la page précédente, nous allons cette fois-ci retourner la valeur d'une cellule.


La fonction SI devra maintenant afficher le tarif en fonction de l'âge :

excel fonction tarif fonctions si imbriquees

Insérez la fonction SI et entrez ensuite le même test logique qu'à la page précédente B2>=18 (qui vérifie si l'âge est plus grand ou égal à 18).

La valeur si VRAI doit être ici la référence à la cellule contenant le tarif adulte et la valeur si FAUX, la référence au tarif enfant :

excel fonction si tarif fonctions imbriquees

Rappelez-vous que les références sont décalées lors de la recopie, il faut donc encore ajouter les $ aux références des tarifs :

excel fonction si tarif dollar fonctions imbriquees

La formule =SI(B2>=18;$F$3;$F$2) est maintenant prête à être recopiée :

excel fonction tarifs recopie fonctions si imbriquees

Le tarif de chacun est alors affiché :

excel fonction tarifs fonctions si imbriquees

Imbriquer une fonction dans une autre

Pour obtenir le résultat souhaité, il sera parfois nécessaire d'imbriquer plusieurs fonctions ...

Ajoutons un tarif supplémentaire pour cet exemple :

excel fonction 3 tarifs fonctions si imbriquees

Dans ce cas, si la personne a moins de 18 ans, le tarif ne change pas. En revanche, pour un adulte 2 tarifs restent possibles (adulte ou retraité), il faut donc ajouter un second test logique.

Pour ouvrir la fenêtre de la fonction, sélectionnez la cellule C2 et cliquez sur "Insérer une fonction" depuis l'onglet "Formules" :

excel fonction si fenetre fonctions imbriquees

Supprimez ensuite le contenu de la valeur si VRAI (puisqu'elle dépendra du second test) :

excel fonction si fonctions imbriquees

Et ajoutez une nouvelle fonction SI en la sélectionnant dans la liste à gauche :

excel fonction si imbriques fonctions imbriquees

Entrez ensuite le second test logique B2>=65 et les tarifs correspondants (sans oublier les $) :

excel fonctions si imbriquees

La formule =SI(B2>=18;SI(B2>=65;$F$4;$F$3);$F$2) contient 2 fonctions SI et permet d'afficher maintenant les tarifs en fonction de 3 tranches d'âge :

excel fonction si imbrication fonctions imbriquees

Le résultat après recopie :

excel fonction si 3 tarifs fonctions imbriquees
Télécharger ce cours au format PDF