Formation Excel : les opérateurs de comparaison

Dans les exemples de la fonction SI, vous avez pu voir un premier opérateur de comparaison >=. Voici les autres opérateurs que vous pouvez utiliser dans vos formules :

=est égal à
<>est différent de
<est plus petit que
<=est plus petit ou égal à
>est plus grand que
>=est plus grand ou égal à

Les fonctions ET et OU

La fonction ET =ET(test_1; test_2; ...) renvoie VRAI si tous les tests sont VRAI.

La fonction OU =OU(test_1; test_2; ...) renvoie VRAI si au moins un des tests est VRAI.

Par exemple, pour afficher VRAI lorsque la personne a au moins 18 ans ET moins de 65 ans (et FAUX dans le cas contraire), entrez =ET(B2>=18;B2<65) :

excel fonction et operateurs comparaison

Les fonctions ET et OU ne peuvent retourner que les valeurs VRAI ou FAUX.

Dans ce cas, pour obtenir d'autres valeurs que VRAI ou FAUX, imbriquez la fonction ET dans une fonction SI à la place du test logique (cela va parfaitement fonctionner car le test logique cherche à déterminer si le résultat est VRAI ou FAUX).

La formule devient alors =SI(ET(B2>=18;B2<65);"Oui";"Non") :

excel fonction si et operateurs comparaison

Plus de fonctions

Vous trouverez des exemples d'utilisation des fonctions les plus courantes sur la page consacrée aux fonctions (accessible via le lien "Fonctions" dans le menu en haut de page).

Exercice

Pour mettre en pratique cette leçon sur les formules et les fonctions, téléchargez l'exercice suivant : exercice-4.xlsx

La première feuille du classeur téléchargé ressemblera à ceci :

excel exercice operateurs comparaison

Commencez par mettre en forme cette feuille de manière à vous rapprocher le plus possible du résultat suivant :

excel exercice commande articles operateurs comparaison

Après avoir mis en forme le tableau, complétez les données manquantes en utilisant des formules et des fonctions (SI et SOMME).

Télécharger ce cours au format PDF